


Spreadsheet

• A spreadsheet is a large sheet having data and
information arranged in rows and columns.

• Excel is one of the most widely used spreadsheet
applications. It is a part of Microsoft Office suite.

• Spreadsheet is quite useful in entering, editing,
analysing and storing data.

• Arithmatic operations with numerical data such as
addition, subtraction, multiplication and division can
be done using Excel. You can sort numbers/ characters
according to some given criteria (like ascending,
descending etc.) and use simple financial,
mathematical and statistical formulas.



FEATURES OF SPREADSHEETS 

• There are a number of features that are available in
Excel to make your task easier. Some of the main
features are:

• 1. AutoSum - helps you to add the contents of a cluster
of adjacent cells.

• 2. List AutoFill - automatically extends cell formatting
when a new item is added to the end of a list.

• 3. AutoFill - allows you to quickly fill cells with
repetitive or sequential data such as chronological
dates or numbers, and repeated text. AutoFill can also
be used to copy functions. You can also alter text and
numbers with this feature.



FEATURES OF SPREADSHEETS 

• 4. AutoShapes toolbar will allow you to draw a number of
geometrical shapes, arrows, flowchart elements, stars and
more. With these shapes you can draw your own graphs.

• 5. Wizard - guides you to work effectively while you work
by displaying various helpful tips and techniques based on
what you are doing.

• 6. Drag and Drop - it will help you to reposition the data
and text by simply dragging the data with the help of
mouse.

• 7. Charts - it will help you in presenting a graphical
representation of your data in the form of Pie, Bar, Line
charts and more.



FEATURES OF SPREADSHEETS 

• 8. PivotTable - it flips and sums data in
seconds and allows you to perform data
analysis and generating reports like periodic
financial statements, statistical reports, etc.
You can also analyse complex data
relationships graphically.

• 9. Shortcut Menus - the commands that are
appropriate to the task that you are doing will
appear by clicking the right mouse button



The Excel Interface

• After starting Excel, you will see two windows
- one within the other. The outer window is
the Application Window and the inner
window is the Workbook Window. When
maximized, the Excel Workbook Window
blends in with the Application Window.





The Application Window

• The Application Window provides the space
for your worksheets and workbook elements
such as charts. The components of the
Application Window are described below:

– The Quick Access Toolbar:

• The Quick Access Toolbar lets you access common
commands no matter which tab is selected. By default,
it includes the Save, Undo, and Repeat commands. You
can add other commands depending on your
preference.



The Application Window

– The Ribbon:
• Excel uses a tabbed Ribbon system instead of

traditional menus. The Ribbon contains multiple tabs,
each with several groups of commands. You will use
these tabs to perform the most common tasks in Excel.

– The Formula Bar:
• In the formula bar, you can enter or edit data, a

formula, or a function that will appear in a specific cell.

– The Name Box:
• The Name box displays the location, or "name" of a

selected cell.



The Workbook Window

• There can be a max of 1,048,576 rows and 16,384
columns in an excel work sheet.

– The Worksheet:

• Excel files are called workbooks. Each workbook holds one
or more worksheets (also known as "spreadsheets").

• Whenever you create a new Excel workbook, it will contain
one worksheet named Sheet1. A worksheet is a grid of
columns and rows where columns are designated by letters
running across the top of the worksheet and rows are
designated by numbers running down the left side of the
worksheet.



The Workbook Window

– The Scrolling Buttons:

• These buttons scroll the display of sheet tabs one at a 
time or to display the first and last grouping of sheet 
tabs and are located to the left of the sheet tabs



The Workbook Window

– The Scroll Bars:

• Your spreadsheet may frequently have more data than 
you can see on the screen at once. Click, hold and drag 
the vertical or horizontal scroll bar depending on what 
part of the page you want to see.



Renaming a worksheet

• Whenever you create a new Excel workbook, it 
will contain worksheet named Sheet1,Sheet2 etc. 
You can rename a worksheet to better reflect its 
content.

1. Right-click the worksheet you wish to rename, 
then select Rename from the worksheet menu. 

2. Type the desired name for the worksheet. 

3. Click anywhere outside of the worksheet, or 
press Enter on your keyboard. The worksheet 
will be renamed. 



Insert a new worksheet

1. Locate and select the New Sheet button/
Insert Worksheet.

2. A new blank worksheet will appear.

• The shortcut key to insert a new worksheet
is: SHIFT + F11.



Delete a worksheet

• Right-click the worksheet you wish to delete,
then select Delete from the worksheet menu.

• The worksheet will be deleted from your
workbook.



Copy a worksheet

• If you need to duplicate the content of one worksheet 
to another, Excel allows you to copy an existing 
worksheet

1. Right-click the worksheet you want to copy, then 
select Move or Copy from the worksheet menu.

2. The Move or Copy dialog box will appear. Choose 
where the sheet will appear in the Before sheet: field.

3. Check the box next to Create a copy, then click OK.

4. The worksheet will be copied. It will have the same 
title as the original worksheet, as well as a version 
number.



Changing the worksheet color

• You can change a worksheet's color to help
organize your worksheets and make your
workbook easier to navigate.

1. Right-click the desired worksheet, and hover the
mouse over Tab Color. The Color menu will
appear.

2. Select the desired color. A live preview of the
new worksheet color will appear as you hover
the mouse over different options.

3. The worksheet color will be changed.



Cells
• Whenever you work with Excel, you'll enter

information, or content, into cells. Cells are
the basic building blocks of a worksheet.

• Every worksheet is made up of thousands of
rectangles, which are called cells. A cell is the
intersection of a row and a column. Columns
are identified by letters (A, B, C), while rows
are identified by numbers (1, 2, 3).



Cells

• Each cell has its own name, or cell address,
based on its column and row. In this example,
the selected cell intersects column C and row
5, so the cell address is C5. The cell address
will also appear in the Name box.



Cell

• You can also select multiple cells at the same
time. A group of cells is known as a cell range.
Rather than a single cell address, you will refer
to a cell range using the cell addresses of the
first and last cells in the cell range, separated
by a colon. For example, a cell range that
included cells A1, A2, A3, A4, and A5 would be
written as A1:A5.



Cell Content

• Any information you enter into a spreadsheet will be
stored in a cell. Each cell can contain several different
kinds of content, including text, formatting, formulas,
and functions.
– Text: Cells can contain text, such as letters, numbers, and

dates.
– Formatting Attributes: Cells can contain formatting

attributes that change the way letters, numbers, and dates
are displayed. For example, percentages can appear as
0.15 or 15%. You can even change a cell's background
color.

– Formulas and Functions: Cells can contain formulas and
functions that calculate cell values.



Use of fill handle

• There may be times when you need to copy
the content of one cell to several other cells in
your worksheet. You could copy and paste the
content into each cell, but this method would
be very time consuming. Instead, you can use
the fill handle to quickly copy and paste
content to adjacent cells in the same row or
column.



Use of fill handle
1. Select the cell(s) containing the content you

wish to use. The fill handle will appear as a
small square in the bottom-right corner of
the selected cell(s).

2. Click, hold, and drag the fill handle until all of
the cells you wish to fill are selected.

3. Release the mouse to fill the selected cells.



To continue a series with the fill handle 

• The fill handle can also be used to continue a
series. Whenever the content of a row or
column follows a sequential order, like
numbers (1, 2, 3) or days (Monday, Tuesday,
Wednesday), the fill handle can guess what
should come next in the series.



Formatting Cells

• Font Formatting:

– By default, the font of each new workbook is set
to Calibri. However, Excel provides a variety of
other fonts you can use to customize your cell
text.



Formatting Cells

• Text Alignment

– By default, any text entered into your worksheet
will be aligned to the bottom-left of a cell.

– Any numbers will be aligned to the bottom-right
of a cell.

– Changing the alignment of your cell content
allows you to choose how the content is displayed
in any cell, which can make your cell content
easier to read.



Formatting Cells

• To change horizontal text alignment:

– Select the cell(s) you wish to modify.

– Select one of the three horizontal alignment
commands on the Home tab. In our example, we'll
choose Center Align.

– The text will realign.



Formatting Cells

• To change vertical text alignment

– Select the cell(s) you wish to modify.

– Select one of the three vertical alignment
commands on the Home tab.

– The text will realign.



Formatting Cells

• Cell borders and fill colors:
– Cell borders and fill colors allow you to create clear

and defined boundaries for different sections of your
worksheet.

• To add a border:
– Select the cell(s) you wish to modify.
– Click the drop-down arrow next to the Borders

command on the Home tab. The Borders dropdown
menu will appear.

– Select the border style you want to use.
– The selected border style will appear.



Formatting Cells

• You can draw borders and change the line
style and color of borders with the Draw
Borders tools at the bottom of the Borders
drop-down menu.



Formatting Cells

• To add a fill color:
– Select the cell(s) you wish to modify.

– Click the drop-down arrow next to the Fill Color
command on the Home tab. The Fill Color menu
will appear.

– Select the fill color you want to use. A live preview
of the new fill color will appear as you hover the
mouse over different options.

– The selected fill color will appear in the selected
cells.



Formatting Cells

• Formatting text and numbers:

– In Excel ,you can apply specific formatting for text
and numbers. Instead of displaying all cell content
in exactly the same way, you can use formatting to
change the appearance of dates, times, decimals,
percentages (%), currency ($), and much more.



Formatting Cells

• To apply number formatting:

– Select the cells(s) you wish to modify.

– Click the drop-down arrow next to the Number
Format command on the Home tab. The Number
Formatting drop-down menu will appear.

– Select the desired formatting option.

– The selected cells will change to the new
formatting style.





Modifying Columns, Rows and Cells

• By default, every row and column of a new workbook is
always set to the same height and width. Excel allows
you to modify column width and row height in
different ways, including wrapping text and merging
cells.

• To modify column width
– Position the mouse over the column line in the column

heading so the white cross becomes a double arrow .

– Click, hold, and drag the mouse to increase or decrease
the column width.

– Release the mouse. The column width will be changed.



Modifying Columns, Rows and Cells

• If you see pound signs (#######) in a cell, it
means that the column is not wide enough to
display the cell content. Simply increase the
column width to show the cell content.



Modifying Columns, Rows and Cells

• Autofit column width:

– The AutoFit feature will allow you to set a
column's width to fit its content automatically.

– Position the mouse over the column line in the
column heading so the white cross becomes a
double arrow .

– Double-click the mouse. The column width will be
changed automatically to fit the content.



Wrapping text and merging cells 

• Whenever you have too much cell content to
be displayed in a single cell, you may decide to
wrap the text or merge the cell rather than
resizing a column.

• Wrapping the text will automatically modify a
cell's row height, allowing cell contents to be
displayed on multiple lines.

• Merging allows you to combine a cell with
adjacent, empty cells to create one large cell.



Wrapping Cells

• Select the cells you wish to wrap.

• Select the Wrap Text command on the Home
tab.

• The text in the selected cells will be wrapped.

– Click the Wrap Text command again to unwrap the
text.



To hide and unhide a row or column 

• Select the column(s) you wish to hide, right-
click the mouse, then select Hide from the
formatting menu.

• The columns will be hidden. The green column
line indicates the location of the hidden
columns.



To hide and unhide a row or column 

• To unhide the columns, select the columns to
the left and right of the hidden columns (in
other words, the columns on both sides of the
hidden columns).

• Right-click the mouse, then select Unhide
from the formatting menu. The hidden
columns will reappear.



Formulas and Functions

• One of the most powerful features in Excel is
the ability to calculate numerical information
using formulas.

• All formulas in Excel must begin with an
equals sign (=). This is because the cell
contains, or is equal to, the formula and the
value it calculates.



Formulas and Functions

• Excel uses standard operators for formulas,
such as a plus sign for addition (+), a minus
sign for subtraction (-), an asterisk for
multiplication (*), a forward slash for division
(/), and a caret (^) for exponents



Cell References 

• While you can create simple formulas in Excel
manually (for example, =2+2 or =5*5), most of
the time you will use cell addresses to create a
formula. This is known as making a cell
reference.

• Using cell references will ensure that your
formulas are always accurate because you can
change the value of referenced cells without
having to rewrite the formula.



Relative and Absolute Cell References

• There are two types of cell references: relative
and absolute.

• Relative and absolute references behave
differently when copied and filled to other
cells.

• Relative references change when a formula is copied to
another cell.

• Absolute references, on the other hand, remain
constant, no matter where they are copied.



Relative cell references

• By default, all cell references are relative
references.

• When copied across multiple cells, they change
based on the relative position of rows and
columns.

• For example, if you copy the formula =A1+B1
from row 1 to row 2, the formula will become
=A2+B2.

• Relative references are especially convenient
whenever you need to repeat the same
calculation across multiple rows or columns.



Absolute cell references 

• Unlike relative references, absolute references
do not change when copied or filled. You can
use an absolute reference to keep a row
and/or column constant.

• An absolute reference is designated in a
formula by the addition of a dollar sign ($). It
can precede the column reference, the row
reference, or both.



Absolute cell references 

• When writing a formula, you can press the F4
key on your keyboard to switch between
relative and absolute cell references. This is an
easy way to quickly insert an absolute
reference.



Functions

• A function is a predefined formula that
performs calculations using specific values in a
particular order.

• Excel includes many common functions that
can be useful for quickly finding the sum,
average, count, maximum value, and
minimum value for a range of cells.

• Formula=A1+A2+A3+A4+A5+A6+A7+A8
Function =SUM(A1:A8)



Parts of a Function

• In order to work correctly, a function must be
written a specific way, which is called the
syntax.

• The basic syntax for a function is an equals
sign (=), the function name (SUM, for
example), and one or more arguments.
Arguments contain the information you want
to calculate.



Functions

• Arguments can refer to both individual cells and cell
ranges and must be enclosed within parentheses. You
can include one argument or multiple arguments,
depending on the syntax required for the function.

• For example, the function =AVERAGE(B1:B9) would
calculate the average of the values in the cell range
B1:B9. This function contains only one argument.

• Multiple arguments must be separated by a comma.
For example, the function =SUM(A1:A3, C1:C2, E2) will
add the values of all the cells in the three arguments.



Functions

Excel has a variety of functions available:

• SUM: This function adds all of the values of the cells in the
argument.

• AVERAGE: This function determines the average of the values
included in the argument. It calculates the sum of the cells and then
divides that value by the number of cells in the argument.

• COUNT: This function counts the number of cells with numerical
data in the argument. This function is useful for quickly counting
items in a cell range.

• MAX: This function determines the highest cell value included in
the argument.

• MIN: This function determines the lowest cell value included in the
argument.



To create a function using the 
AutoSum command 

• The AutoSum command allows you to
automatically insert the most common
functions into your formula, including SUM,
AVERAGE, COUNT, MIN, and MAX.



Functions

• SUM :

– Formula: =SUM(5, 5) or =SUM(A1, B1) or
=SUM(A1:B5)

– The SUM formula does exactly what you would
expect. It allows you to add 2 or more numbers
together. You can use cell references as well in this
formula.



Functions

• COUNT 

– Formula: =COUNT(A1:A10) 

– The count formula counts the number of cells in a 
range that have numbers in them. 

– It only counts the cells where there are numbers. 



Functions

• COUNTA

– Formula: =COUNTA(A1:A10) 

– Counts the number of non-empty cells in a range. 

– It will count cells that have numbers and/or any 
other characters in them. The COUNTA Formula 
works with all data types.

– It counts the number of non-empty cells no 
matter the data type. 



Functions

• LEN 

– Formula: =LEN(A1)

– The LEN formula counts the number of characters 
in a cell. This includes spaces!



Functions

• VLOOKUP is an Excel function to lookup and retrieve data from a
specific column in table.

VLOOKUP (lookup_value, table_array, col_index_num, [range_lookup])
Where
• lookup_value − is the value you want to look up. Lookup_value can

be a value or a reference to a cell. Lookup_value must be in the first
column of the range of cells you specify in table_array

• table_array − is the range of cells in which the VLOOKUP will search
for the lookup_value and the return value. table_array must contain
– the lookup_value in the first column, and
– the return value you want to find



Functions

• col_index_num − is the column number in the table_array that
contains the return value. The numbers start with 1 for the left-
most column of table-array

• range_lookup − is an optional logical value that specifies whether
you want VLOOKUP to find an exact match or an approximate
match. range_lookup can be
– omitted, in which case it is assumed to be TRUE and VLOOKUP tries to

find an approximate match
– TRUE, in which case VLOOKUP tries to find an approximate match. In

other words, if an exact match is not found, the next largest value that
is less than lookup_value is returned

– FALSE, in which case VLOOKUP tries to find an exact match
– 1, in which case it is assumed to be TRUE and VLOOKUP tries to find an

approximate match
– 0, in which case it is assumed to be FALSE and VLOOKUP tries to find

an exact match



Functions

• IF Statements

– allows you to make logical comparisons between a 
value and what you expect.

– Formula: =IF(logical_statement, return this if 
logical statement is true, return this if logical 
statement is false).

– Nesting of IF statements is possible but Excel only 
allows this till 64 Levels.

https://www.exceltrick.com/formulas_macros/excel-nested-if


Freezing Panes and View Options 

• To freeze rows :
– You may want to see certain rows or columns all the

time in your worksheet, especially header cells. By
freezing rows or columns in place, you'll be able to
scroll through your content while continuing to view
the frozen cells.

• Select the row below the row(s) you wish to
freeze.

• Click the View tab on the Ribbon.
• Select the Freeze Panes command, then choose

Freeze Panes from the drop-down menu.



Charts

• Chart is a visual representation of data from a
worksheet that can bring more understanding
to the data than just looking at the numbers.

• A chart is a powerful tool that allows you to
visually display data in a variety of different
chart formats such as Bar, Column, Pie, Line,
Area, Doughnut, Scatter, Surface, or Radar
charts.



Types of Charts

• Column charts use vertical bars to represent data.
They can work with many different types of data, but
they're most frequently used for comparing
information.

• Line charts are ideal for showing trends. The data
points are connected with lines, making it easy to see
whether values are increasing or decreasing over
time.

• Pie charts make it easy to compare proportions. Each
value is shown as a slice of the pie, so it's easy to see
which values make up the percentage of a whole.



Types of Charts

• Bar charts work just like Column charts, but
they use horizontal bars instead of vertical
bars.

• Area charts are similar to line charts, except
that the areas under the lines are filled in.

• Surface charts allow you to display data across
a 3D landscape. They work best with large
data sets, allowing you to see a variety of
information at the same time.



Inserting a Chart

• Select the cells you want to chart, including
the column titles and row labels. These cells
will be the source data for the chart.

• From the Insert tab, click the desired Chart
command.

• Choose the desired chart type from the drop-
down menu.

• The selected chart will be inserted in the
worksheet.



Pivot Table

• A pivot table is a statistics tool that summarizes
and reorganizes selected columns and rows of
data in a spreadsheet to obtain a desired report.

• The tool does not actually change the
spreadsheet or database itself, it simply “pivots”
or turns the data to view it from different
perspectives.

• Pivot tables are especially useful with large
amounts of data that would be time-consuming
to calculate by hand.



Pivot Table

• The major features of a PivotTable are as follows-

– Creating a PivotTable is extremely simple and fast

– Enabling churning of data instantly by simple dragging
of fields, sorting and filtering and different
calculations on the data.

– Ability to create reports on the fly.

– Producing multiple reports from the same PivotTable
in a matter of seconds.

– Providing interactive reports to synchronize with the
audience.



Inserting a Pivot Table

• Select the cells you want to create a PivotTable from.

• Note: Your data shouldn't have any empty rows or
columns. It must have only a single-row heading.

• Select Insert > PivotTable.

• Under Choose the data that you want to analyze,
select Select a table or range.

• In Table/Range, verify the cell range.

• Under Choose where you want the PivotTable report to be
placed, select New worksheet to place the PivotTable in a
new worksheet or Existing worksheet and then select the
location you want the PivotTable to appear.

• Select OK.



Excel Macro

• An Excel macro is an action or a set of actions that you can
record, give a name, save and run as many times as you
want and whenever you want. When you create a macro,
you are recording your mouse clicks and keystrokes.

• When you run a saved macro, the recorded mouse clicks
and keystrokes will be executed in the same sequence as
they are recorded.

• Macros help you to save time on repetitive tasks involved in
data manipulation and data reports that are required to be
done frequently.

• An Excel macro is typically created by recording a sequence
of keyboard and mouse actions using the Macro Recorder.
It can also be created using Visual Basic.



Excel Macro

• You can create a macro with Excel commands by
recording the key strokes and mouse clicks, giving
the macro a name and specifying how to store the
macro. A macro thus recorded can be run with an
Excel command.

• Suppose you have to collect certain results
repeatedly in the following format –



Recording a Macro

• To record a macro do the following –
– Click the VIEW tab on the Ribbon. 

– Click Macros in the Macros group.

– Select Record Macro from the dropdown list.

– The Record Macro dialog box appears.

– Type MyFirstMacro in the Macro name box.

– Type A Simple Macro in the Description box and click 
OK. 

• whatever key strokes and mouse clicks you do, 
will be recorded now



Recording a Macro

– Click in the cell B2. 

– Create the table. 

– Click in a different cell in the worksheet. 

– Click the VIEW tab on the Ribbon. 

– Click Macros. 

– Select Stop Recording from the dropdown list.

• The macro recording is completed.



Running a macro

• You can run the macro you have recorded any
number of times you want.

• To run the macro, do the following –
– Click on a new worksheet. Note the active cell.

– Click the VIEW tab on the Ribbon.

– Click Macros.

– Select View Macros from the dropdown list.

– The Macro dialog box appears.

– Click the macro name.

– Click the run button.


